# 从1.1升级到1.2

目前1.2版本还在开发中,大家可以下载1.2.0-next.x (opens new window)版本

# Breaking Changes

  • LogicFlow 1.2版本并没有在1.1版本基础上有巨大变化,在1.2版本,我们对源码中一些拼写错误进行了修改,但是不涉及到 LogicFlow 提供的 API。但是 LogicFlow 提供的基于继承的自定义机制,可以让熟悉 LogicFlow 源码的同学绕过 LogicFlow 文档上的API进行高度自定义,所以我们选择发布一个新的 minor 版本。若您是基于LogicFlow提供的API或者示例开发,可以直接升级。若您在LogicFlow 上涉及到绕过API进行自定义,可以安装 VSCode 插件 Code Spell Checker 快速找到拼写错误。

  • LogicFlow在1.1提供了拖动节点或者连线到画布边界时会自动扩展画布区域,在后续收到的反馈来看,这个交互会带来一定的解释成本,所以在1.2版本默认关闭此功能。大家可以在初始化LogicFlow时传如参数autoExpandtrue来开启,现在改成默认为false

# 1.2.0-next.2